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1 Navigation tips
Navigating in the HTML document
To navigate through the documentation sequentially:
• Click the Next arrow (→) for the next topic.

• Click Previous arrow (←) for the previous topic.
Navigating using the Internet browser toolbar:
• To return to the last page you viewed, click the Back button on the browser toolbar.

Navigating to documentation on the HP website
• From the URLs in this guide, you may need to make several selections to get to your specific

server documentation.
• For online access to technical documentation, self-help resources, live chat assistance,

community forums of IT experts, technical knowledge base, remote monitoring and diagnostic
tools, go to http://www.hp.com/support.

• For the latest versions of selected technical documentation, go to http://docs.hp.com.
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2 Notices
© Copyright 2008, 2012 Hewlett-Packard Development Company, L.P.
The information contained herein is subject to change without notice. The only warranties for HP
products and services are set forth in the express warranty statements accompanying such products
and services. Nothing herein should be construed as constituting an additional warranty. HP shall
not be liable for technical or editorial errors or omissions contained herein.
Confidential computer software. Valid license from HP required for possession, use or copying.
Consistent with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software
Documentation, and Technical Data for Commercial Items are licensed to the U.S. Government
under vendor's standard commercial license.
Microsoft®, Windows Server™, and Windows NT® are U.S. registered trademarks of Microsoft
Corporation. Java is a registered trademark of Oracle Corporation and/or its affiliates.

Intended audience
This document is for the person who installs, administers, and troubleshoots servers and storage
systems. HP assumes you are qualified in the servicing of computer equipment and trained in
recognizing hazards in products with hazardous energy levels.
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3 Overview
Introduction

IMPORTANT:
• If your server has a factory-installed operating system, then do not boot from the HP SmartStart

CD or Support Pack for Proliants or HP Intelligent Provisioning when powering up the server
for the first time. The SmartStart CD or HP Intelligent Provisioning must only be used if it is
necessary to reinstall the operating system.

• Complete the operating system installation before installing any additional hardware options.

This guide provides instructions for completing the installation of the following factory-installed
operating systems:
• Microsoft® Windows Server™ 2008 R2 Standard.

• Microsoft® Windows Server™ 2012 Standard.

Features
The operating system is preloaded on the server disk drive before the server is shipped to you.
Also, the latest drivers are downloaded onto the server disk drive and integrated with the preloaded
operating system.
The normal server operating system installation process is shortened for a preloaded server operating
system. This installation requires approximately 30 minutes, compared to the normal CD installation
time of 90 minutes. The user-specific information such as the server name, IP address, and regional
settings must be entered during the installation process.
The HP factory-installed software for Microsoft® Windows Server™ 2008 R2 Standard and
Microsoft® Windows Server™ 2012 Standard are as follows:
• Ready to run – You are guided through a mini-setup wizard, after which any HP specific

components are installed and, when possible, configured. After the required restarts of the
operating system, the Microsoft® Windows Server™ 2008 R2 Standard or Microsoft®
Windows Server™ 2012 Standard installation is complete and ready to perform necessary
user configuration.

• Preconfigured with the networking protocols TCP/IP, and the SNMP service – These services
are required for effective network management, and enable the HP Management Agents for
Servers to communicate with HP Systems Insight Manager.

• Operating System Activation – If this product was purchased directly from HP, this product is
pre-activated. HP has configured the operating system so that customer activation is not
required. If this product was purchased from your local authorized reseller, you have 60-days
from the installation of the product to complete product activation - online by phone directly
with Microsoft. Please follow activation instructions upon installation of the operating system.
In addition, Microsoft® is allowing extension of the 60-day activation period up to 240 days.
For more information, see the Microsoft® knowledge base article (http://
support.microsoft.com/kb/948472).

• Capable of out-of-the-box management of the server with the installation of the HP Management
Agents for Servers – The HP Management Agents monitor server performance and configuration,
as well as the performance of the operating system. The HP Management Agents help prevent
problems before users are affected by issuing alerts when faults occur.

• Preconfigured with NTFS – Many new features in Microsoft® Windows Server™ 2008 R2
Standard and Microsoft® Windows Server™ 2012 Standard require NTFS, including the
ability to promote the server to a domain controller to use Microsoft® Active Directory, and

6 Overview

http://support.microsoft.com/kb/948472
http://support.microsoft.com/kb/948472


NTFS offers greater security. Review the Microsoft® Windows Server™ 2008 R2 Standard
or Microsoft® Windows Server™ 2012 Standard software documentation to properly configure
the server and to understand how to use NTFS with Microsoft® Windows Server™ 2008 R2
Standard and Microsoft® Windows Server™ 2012 Standard, while concurrently using previous
versions of Microsoft® Windows NT® in a network infrastructure.

For additional information about Microsoft® Windows Server™ 2008 R2 Standard and Microsoft®
Windows Server™ 2012 Standard, see the HP website (http://h18000.www1.hp.com/products/
servers/software/factory-installed.html) or the Microsoft website (http://www.microsoft.com/
windowsserver2008).
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4 Gathering information
Certificate of authenticity

IMPORTANT: Locate the COA label on the server, and record the product key for future reference.

The COA label is used for the following:
• Upgrade the factory-installed operating system using the Microsoft® Upgrade program for

license validation.
• Reinstall the operating system because of a failure that has permanently disabled it.
The COA label location varies by server model. On rack-mounted server models, the COA label
is located either on the front section of the right panel or on the right front corner of the top panel.
On tower models, the COA label is located towards the rear of the top panel of the server.

NOTE: The product key shown below is a general representation and may not be for the specific
product purchased.

NOTE: The product key is not needed at the time of the initial operating system installation
because, the server comes from the factory with a product key already installed.

Record the product key in the space provided when the server is initially installed and the COA
label is most easily accessible.

For more information about licensing Windows Server® operating system products on HP ProLiant
servers, see Microsoft® Windows® Server Licensing FAQ guide (http://h20195.www2.hp.com/
v2/GetPDF.aspx/4AA2-7877ENW.pdf).
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5 Installation
Before installing the operating system

IMPORTANT:
• Before powering up the server and configuring the operating system software, connect the

server hardware as described in the server user guide. Do not install additional hardware
devices until the software installation is complete.

• After the installation of the operating system, if prompted for HP driver files, enter the path:
C:\Drivers. Driver files are located in subdirectories in this path. To view the directory,
click Browse.

• To successfully complete the software installation, TCP/IP services must be installed, and the
server must be connected to an active network connection.

• Windows® Server 2008 R2 Standard and Windows® Server 2012 Standard operating
systems ship with three to four partitions, 1 GB, 20 GB, 4 GB and 4 GB respectively. The 1
GB partition is system reserved and hidden. Do not delete or format this 1 GB system partition.
Third and forth partitions are created for the installation purpose and will be deleted
automatically during initial operating system setup.

Installing the operating system

Windows Server 2008 R2 standard
To install Windows Server 2008 R2 Standard:
1. Power up the server. The HP Welcome screen appears.
2. If you had ordered for Multi lingual image, you will be prompted to select the desired language.

Choose appropriate language and press the appropriate key to continue.
3. On the HP Welcome screen, if prompted for selecting the Service pack level then, choose the

desired service pack level and press the appropriate key to continue.

NOTE: For all Gen8 servers, Service pack 1 is selected by default. Next, Server software
license screen appears.

4. To accept the license agreements, press the appropriate key.
5. On the OS Partition screen, choose one of the following to set the operating system partition

size:
• Typical disk size option. Typical size cannot be altered as it is the minimum recommended

value. The partition size is normally 20 GB or greater.
• Custom disk size option. This option enables you to set the partition size between typical

and maximum disk capacity.
6. Enter the administrator password and confirm to proceed.
7. Read the Software license agreement and press the appropriate key to accept and continue.
8. Follow the online prompts, making keyboard or mouse entries only when prompted by the

system. During the software installation several status screens appear that describe the process.

CAUTION: The server requires a reboot at the end of the installation. Do not power down the
server at any time during the installation process. Any power interruption during the installation
process could prevent proper completion of the installation and prevent the operating system from
restarting.
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NOTE: You can view and print the EULA after the installation is completed by clicking Start and
selecting All Programs>Pre-Install Features>End-User License Agreement..

Windows Server 2012 Standard
To install Windows Server 2012 Standard:
1. Power up the server.
2. You will be prompted to select the desired language. Choose the appropriate language and

click Continue.
3. On the HPWelcome screen, if prompted for selecting the Service pack level, choose the desired

service pack level and press the appropriate key to continue.

NOTE: For all Gen8 servers Service pack 1 is selected by default.

4. Click Continue.
5. Click Microsoft EULA.
6. Read the Microsoft End User License Agreement for Microsoft Windows Pre-installation

Environment, select Agree to accept the Microsoft license agreement and click Continue.
7. Read the HP End User License Agreement, select Agree to accept the HP End User license

agreement.
8. Click the Ancillary License to check all third party Ancillary Licensed software used by HP.
9. Click Continue.
10. On the OS Partition screen, choose one of the following to set the operating system partition

size:
• Typical disk size option. Typical size cannot be altered as it is the minimum recommended

value. The partition size is normally 20 GB or greater.
• Custom disk size option. This option enables you to set the partition size between typical

and maximum disk capacity.
11. Click Continue.
12. On the User Credentials page, enter the administrator password and re-enter to confirm the

password.
13. Click Continue.
14. Read the Microsoft Operating System End User License Agreement and select Agree to accept

the Microsoft End User License Agreement.
15. Click Continue.
16. Click Continue to start installation.
17. Follow the online prompts, keyboard or mouse entries only when prompted by the system.

During the software installation, several status screens appear that describe the process.

CAUTION: The server requires a reboot at the end of the installation. Do not power down the
server at any time during the installation process. Any power interruption during the installation
process could prevent proper completion of the installation and prevent the operating system from
restarting.

NOTE: You can view and print the EULA after the installation is completed by clicking button
from keyboard and right-click anywhere on the Start page and select All Apps>Pre-Install
Features>End-User License Agreement.
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Signed drivers
During the installation of the operating system, caution messages concerning unsigned software
drivers might appear. The caution message states, Digital signature is not found, when
drivers are about to be installed. When prompted, click Yes to accept the drivers and continue the
installation. If you are prompted to reboot the server, click No. After the operating system installation
is complete, download digitally signed drivers (http://www.hp.com/support/files).

Found New Hardware Wizard
The Found New Hardware Wizard might appear during the operating system installation. If this
wizard appears, click Cancel.

IMPORTANT: Do not attempt to install the drivers during the operating system installation because
the server might automatically reboot before the driver installation is completed. This action could
result in the incorrect installation of a device.

To install drivers for unknown devices in device manager. After the operating system installation:
1. Click Start>Administrative Tools>Computer Management.
2. From the left column, select Device Manager.
3. Right-click the component displaying the yellow mark, and then select Update Driver Software.
4. Click Browse my computer for Driver option.
5. Enter the following path in the text box:

C:\Drivers

6. Click Next.
7. On the Driver Files Search Results screen, click Next.
8. To complete the Found New Hardware Wizard, click Close.
The setup process begins. Wait for the entire setup process to complete, including any requested
restarts, before interrupting this process or powering down the server. After the setup process
completes, you can configure the server.

IMPORTANT: The system might complete the driver installation after the first login. Do not perform
any actions on the Initial Configuration Task screen. If additional drivers are loaded, the system
completes the driver installation and automatically reboots. The next time the system presents a
login prompt, log in and use the new operating system.

Automatic configuration
Some steps of the setup process are automatically configured, and these configuration screens do
not appear. For information about changing any preconfigured information, see the Operating
system documentation. Automatically configured parameters that may require later changes include:
• Licensing mode – By default, the server licensing mode is set to per-device or per-user with a

five device or user count. For information about licensing, see the online help or the Operating
system documentation.

• Administrator password – The administrator password is provided by the user during initial
setup. For procedures to change the administrator password after the installation is complete,
see “Changing the administrator password for Windows Server 2008 R2 Standard” (page 12).

• Dynamic disk upgrade – The operating system is preinstalled on an approximately 20 GB
partition. On an array controller, the logical drive size is set to the maximum size of the drive.
The logical drive of array controllers contains 10 to 15 MB of available space to support a
dynamic disk upgrade.

NOTE: The dynamic disk upgrade is optional. For information about dynamic disk upgrades,
see the Operating system documentation. After upgrading to dynamic disk, the emergency
repair disk must be updated.
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6 Post-installation tasks
Windows Server 2008 R2 Standard and Windows Server 2012 Standard

To log into the server after completing the initial software installation:
1. On the server console, press Ctrl+Alt+Delete button from keyboard and enter the password

which you provided during initial setup.
2. By default, computer name is set to a default value, which can be changed as required.

Changing the administrator password for Windows Server 2008 R2
Standard

The administrator password can be changed by pressing the Ctrl+Alt+Delete keys and clicking
Change Password or by completing the following steps:
1. Click Start, and select All Programs>Administrative Tools>Computer Management.
2. Expand the System Tools directory, and then expand the Local User and Groups directory.
3. Select the Users folder.
4. Right-click Administrator, which appears on the right side of the window, and select Set

Password. A warning message appears.
5. Click Proceed to continue.
6. Enter the new password in the New Password field, and re-enter it in the Confirm Password

field.
7. Click OK.
8. Click OK to complete the process.

CAUTION: Do not lose or forget the administrator password. This password is required to
re-configure the server.

For more information about changing the administrator password, see the Operating system
documentation.

Changing the administrator password for Windows Server 2012 Standard
The administrator password can be changed by pressing the Ctrl+Alt+Delete keys and click the
Change password or by complete the following steps:

1. Press button from the keyboard, and select Administrative Tools>Computer Management.
2. Expand the System Tools directory, and then expand the Local Users and Groups directory.
3. Select the Users folder.
4. Right-click Administrator, which appears on the right side of the window, and select Set

Password. A warning message appears.
5. Click Proceed to continue.
6. Enter the new password in the New Password field, and re-enter it in the Confirm Password

field.
7. Click OK.
8. Click OK to complete the process.

CAUTION: Do not lose or forget the administrator password. This password is required to
re-configure the server.

For more information about changing the administrator password, see the Operating system
documentation.
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Altering regional settings for Windows Server 2008 R2 Standard
If the server is not operating under the default regional settings, alter the regional settings. The
regional settings, controls the keyboard language and allows to set the local format for sorting
and displaying time, date, numbers, and currency for a specified region.
To alter regional settings for Windows Server 2008 R2 Standard:
1. Click Start, and select Control Panel.
2. Double-click Regional and Language Options.
3. Click the Administrative tab.
4. To select the correct locale, click the Change system locale tab and then select the locale from

the list.
5. Click the Keyboard & Languages tab, and then click Change keyboards. The Input Languages

window appears.
6. To select the Input Languages window, click Add.
7. At the Add Input Language window, select the Keyboard Layout/IME, and then correct the

Input Language.
8. Click OK.
9. From the list, select the correct Default input language.
10. To exit the Text Services and Input Languages window, click OK.
11. To exit the Regional and Language Options window, click OK.

Altering regional settings for Windows Server 2012 Standard
If the server is not operating under the default regional settings, alter the regional settings. The
regional settings, controls the keyboard language and allows to set the local format for sorting
and displaying time, date, numbers, and currency for a specified region.
To alter regional settings for Windows Server 2012 Standard:

1. Press button from keyboard, and select Control Panel.
2. Make sure View By option is set to Category and click Clock, Language, and Region options.
3. Click Region.
4. Click Administrative tab.
5. To select the correct locale, click the Change system locale tab and then select locale from the

list.
6. Click OK.
7. To select the Input Languages window, go to Control panel, select the Clock, Language, and

Region options.
8. Click Language.
9. Click Add a language and select your desired language.
10. Click Add.
11. Close the Control Panel.

Installing Microsoft Internet Information Service (IIS) for Windows Server
2008 R2 Standard

IMPORTANT: The server must be connected to an active network connection to complete the
installation of networking components, such as Microsoft® Internet Information Service and Active
Directory.

To install Microsoft Internet Information Service (IIS) for Windows Server 2008 R2 Standard:
1. Click Start, and then select Administrative Tools>Server Manager.
2. In the left column, click Roles.
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3. Select Add Roles, and then to proceed, click Next.
4. Select the Web Server (IIS) component check box.
5. To automatically install the dependencies for the service, click Add required roles.
6. Click Next.
7. Select the Roles Service as required and then click Next.
8. Click Install.
9. To complete the installation, click Close.

Installing Microsoft Internet Information Service for Windows Server 2012
Standard

To install Microsoft Internet Information Service (IIS) for Windows Server 2012 Standard:

1. Press button from keyboard, and then select Administrative Tools>Server Manager.
2. On the Manage menu, click Add Roles and Features.
3. On the Before you begin page, verify that your destination server and network environment

are prepared for the role and feature you want to install. Click Next.
4. On the Select installation type page, select Role-based or feature-based installation and then,

click Next.
5. On the Select installation type page, select a server from the server pool and then, click Next.
6. On the Select installation type page, Select Web Server (IIS), then select Include Management

Tools (if required), click Add Features.
7. Click Next.
8. Click Next.
9. Read the information and click Next.
10. Select all the required Role services to install for Web Server (IIS).
11. Click Next.
12. On the Confirm installation selections page, select Restart the destination server automatically

if required, and then click Install.
13. When installation is finished, verify the installation by opening the All Servers page in Server

Manager, selecting a server on which you installed Web Server (IIS), and viewing the Roles
and Features title on the page for the selected server.

Installing Lights-Out management features
IMPORTANT: The Microsoft® Hardware Wizard detects iLO controller as a Base System Device.
The Hardware Wizard continues to appear until the driver installation is completed.

If you have purchased a server with an iLO controller installed, use the following procedure to
complete the installation. Do not attempt to install the device driver until the operating system is
installed.
1. In the Found New Hardware Wizard window, click Locate and install driver software.
2. Select Search for a Suitable Driver for My Device.
3. Click Next.
4. Select Specify a Location, and then clear the Floppy Drive and CD-ROM check boxes.
5. Click Next.
6. Enter the following path in the text box:

C:\Drivers

7. Click OK.
8. On the Driver Files Search Results screen, click Next, and then click Finish.

14 Post-installation tasks



Configuring the disk drives
The primary logical drive, which contains the operating system, is the only drive on the server that
is configured during the operating system installation. Additional space that is not partitioned is
also located on the primary drive. This non partitioned space and any additional disk drives on
the server must be partitioned and formatted using Disk Administrator before they can be available
for use.
If an array controller has been purchased with the server, see“Configuring array controllers”
(page 25) for procedures.
1. Click Start, and then select All Programs>Administrative Tools>Computer Management.
2. Expand the Storage directory, and then select Disk Management. The disk and logical drive

information appears on the right side of the window.
3. If the new logical drive created by the ACU does not appear on the bottom right side of the

Computer Management window as an unallocated space, click Action, and then click Rescan
Disks.

4. On the bottom right panel, right-click Disk 1 and then select Initialize Disk.
5. On the Initialize Disk screen, select Disk 1, and then click OK. The disk is identified as a Basic

disk.
6. Right-click the box containing the disk size, which is labeled Unallocated, and then select New

Volume (Simple, Spanned, Striped, Mirror).
7. On the New Partition Wizard screen, click Next.
8. To use the maximum disk space, click Next or at the Specify Volume Size screen, enter the

size you want for the partition.
9. Click Next to accept the drive letter assigned by default at the Assign Drive Letter or Path

screen. The Format Partition screen appears.
10. To format the drive, select the appropriate file system format (the default selection is NTFS)

and the Allocation Unit Size.
a. Enter the Volume Label or accept the default label.

11. (Optional) Select Perform a quick format and Enable file and folder compression.
12. If the drive will not be formatted, select Do not format this partition.
13. Click Next.
14. On the Completing the New Partition Wizard screen, click Finish. The partition is formatted

to the file system that was selected and is labeled Healthy at the completion of the format.
For more information on configuring the new disk drives and upgrading to dynamic disks, see the
Operating system documentation.

Creating an additional page file
When additional memory or software applications are installed on the server, errors can occur in
the event log, indicating that the C: drive is nearing capacity. To solve this problem, move
applications located on the C: drive to another partition or create a page file. Creating the
page file on a separate partition to support the amount of memory in the server is the most efficient
solution.
After an additional page file is created, set the page file on the boot partition to the amount of
memory in the server. For additional information about creating page files, see the Help file, which
can be accessed by clicking Start and selecting Help and Support if your operating system is

Windows Server 2008 R2. But, If your operating system is Windows Server 2012, Press button
from the keyboard, right click anywhere on Start Page and click on All Apss>Windows System
>Help and Support.
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Installing tape drives
If you have purchased a tape drive for your server, you might need to manually install support for
the tape drive.
1. Click Start, and then select All Programs>Administrative Tools>Computer Management>Device

Manager. Device Manager displays all devices on the right side of the screen.
2. Select the tape device. The tape drive is listed in the Other Devices category under the ?

(question mark) icon, which indicates an unknown device until the correct driver is installed.
3. Right-click the tape device, and then select Properties.
4. Click the Driver tab, and then click Update Driver. The Update Device Driver Wizard opens.
5. Click Next.
6. Select Search for a suitable driver for my device.
7. Click Next.
8. Select Specify a location, and then clear all the other options.
9. Click Next.
10. Enter the following path in the Device Driver Wizard field:

C:\DRIVERS

11. Click OK. The driver search results display the appropriate device.
12. If an incorrect device appears, click Back, and then reselect the correct device.
13. Click Next to install the driver.
14. To return to the Computer Management screen, click Finish>Close.
The tape driver installation is complete. The tape device now appears in the Tape Drive category
on the Computer Management screen.

Event log errors
After the ProLiant Installation Utility is complete, event log error messages related to certain controller
drivers might appear. These messages are expected at this time and do not affect the performance
of the server or the operating system. Possible messages are as follows:
• The device, \Device\scsi\adpul60ml, did not respond within the

timeout period.

• The device, \Device\scsi\cpqfcalm1, did not respond within the
timeout period.

• Unable to read IO control information from NBT device. Refer to article
#Q257760 on the Microsoft® website (http://www.microsoft.com).

Backing up the server
After you complete the software installation and the server is operational, back up the server using
a tape backup system in conjunction with approved tape backup software.

Configuring network protocols
The TCP/IP and SNMP services are automatically installed. The HP Management Agents for servers
require TCP/IP and SNMP services to communicate with HP Systems Insight Manager. To disable
the SNMP service, see the Operating system documentation. Microsoft® Windows Server™ 2008
R2 Standard and Microsoft® Windows Server™ 2012 Standard require TCP/IP to be enabled.

Setting up Remote Access Server for Microsoft Windows Server 2008 R2 Standard
To setup Remote Access Server for Microsoft® Windows Server™ 2008 R2 Standard:
1. Click Start, and select Control Panel.
2. Click Network and Internet.

16 Post-installation tasks

http://www.microsoft.com/en-us/default.aspx


3. Double-click Network and sharing section.
4. Click Setup a new Connection or Network.
5. Complete the setup as prompted.
For more information on required networking parameters, see the Operating system documentation.

Setting up Remote Access Server for Microsoft Windows Server 2012 Standard
To setup Remote Access Server (RAS) for Microsoft® Windows Server™ 2012 Standard:

1. Click button and select Control Panel.
2. Click Network and Internet.
3. Click Network and Sharing Center.
4. Click Setup a new connection or network.
5. Complete the setup as prompted.
For more information on required networking parameters, see the Operating system documentation.

Installing Java Virtual Machine
The Java™ Virtual Machine utility (http://www.java.com) must be downloaded and installed on
your server to completely and properly view some web pages using Internet Explorer 6.0. For
example, when viewing the Web Agent Help from the System Management Homepage, text that
appears in the left column of the Help screen is not displayed properly if Java™ Virtual Machine
is not installed.

Enabling BitLocker drive encryption
To instal BitLocker Drive Encryption on Windows® Server R2 Standard:
1. Add BitLocker feature from Server manager and reboot the server.
2. After the operating system boots, log in as administrator, go to Control Panel, click Security,

and then click BitLocker Drive Encryption.
3. If the User Account Control dialog box appears, confirm the action and then click Continue.

The BitLocker Drive Encryption page appears.
4. Click Turn On BitLocker on the operating system volume. The following warning appears:

BitLocker encryption might have a performance impact on your server.
If TPM (Trusted Platform Module) is not initialized, the TPM Security Hardware wizard appears.
Follow the directions to initialize the TPM. You must restart or shut down your computer for
the changes to take place.

5. On the Save the recovery password page, the following options appear:
• Save the password on a USB drive. This saves the password to a USB flash drive.

• Save the password in a folder. This saves the password to a folder on a network drive
or other location.

• Print the password. This prints the password.
Use one or more of these options to preserve the recovery password. For each option,
select the option and follow the wizard steps to set the location for saving or printing the
recovery password.

6. When you have finished saving the recovery password, click Next. Encrypt the selected disk
volume page appears.
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IMPORTANT: The recovery password is required in the event the encrypted disk is moved
to another computer, or changes are made to the system startup information. This password
is so important that HP recommends that you make additional copies of the password and
store it in a safe place apart from the computer to assure access to your data. Your recovery
password is needed to unlock the encrypted data on the volume if BitLocker enters a locked
state. This recovery password is unique to this particular BitLocker encryption. You cannot use
it to recover encrypted data from any other BitLocker encryption session.

7. Confirm that the Run BitLocker System check box is selected, and then click Continue.
8. Click Restart Now. The computer restarts and BitLocker verifies if the computer is

BitLocker-compatible and ready for encryption. If it is not, an error message alerting you to
the problem appears.

9. If it is ready for encryption, the Encryption in Progress status bar appears. You can monitor
the ongoing completion status of the disk volume encryption by dragging your mouse cursor
over the BitLocker Drive Encryption icon in the notification area at the bottom of your screen.
By completing this procedure, you have encrypted the operating system volume and created
a recovery password unique to this volume. The next time you log in, you see no change. If
the TPM ever changes or cannot be accessed and if there are changes to key system files, or
if someone tries to start the computer from a product CD or DVD to circumvent the operating
system, the computer switches to recovery mode until the recovery password is supplied.
For more information regarding BitLocker, see the Microsoft® website: (http://
technet.microsoft.com/en-us/library/cc732774.aspx).

To install BitLocker Drive Encryption on Windows® Server 2012 Standard:
1. Add BitLocker feature from Server manager and reboot the server.
2. After the operating system boots, log in as administrator, go to Control Panel, click on BitLocker

Drive Encryption, and then click Turn on BitLocker on the operating system volume.
3. If the User Account Control dialog box appears, confirm the action and then click Continue.

The BitLocker Drive Encryption page appears.
4. One of the following warning appears:

a. BitLocker encryption may have a performance impact on your server. If your TPM (Trusted
Platform Module) is not initialized, the TPM Security Hardware wizard appears. Follow
the directions to initialize the TPM. You must restart or shut down your computer for the
changes to occur.

b. If TPM (Trusted Platform Module) is not available then the following error message is
displayed: This device cannot use a Trusted Platform Moudule. Your
administrator must set the “Allow Bitlocker without a compatible
TPM” option in the “Require additional authentication at startup”
policy for OS volumes.

To solve this issue:

1. Press +R to access the Run command.
2. Type MMC.
3. Click File >Add/Remove Snap-in.
4. Select Group Policy Object Editor under available snap-ins and click Add to selected

snap-ins.
5. Make sure Local computer is selected and click Finish.
6. Click OK.
7. Expand Local computer policy >Computer Configuration >Administrative Templates

>Windows Components>BitLocker Drive Encryption>Operating System Drives, then select
the policy Require additional authentication at startup and enable it.

8. Click Apply and OK.
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9. Collapse all the path.
10. Click File >Exit (save the MMC console if required).

5. Repeat the step 2.
6. On the BitLocker Drive Encryption page, select one of the following method to unlock your

drive at startup:
• Insert a USB flash drive.

• Enter a Password.
7. On How do you want to back up your recovery key page, the following options appear:

• Save to a USB flash drive – Saves the password in the USB flash drive.

• Save to a file – saves the password in the file on a network drive or other location.

• Print the recovery key – Prints the password.
Use one or more of these options to preserve the recovery password. For each option,
select the option and follow the wizard steps to set the location for saving or printing the
recovery password.

8. After saving the recovery password, click Next. The Encrypt the selected disk volume page
appears.

IMPORTANT: The recovery password is required in the event the encrypted disk is moved
to another computer, or changes are made to the system startup information. HP recommends
to create additional copies of the password and store it in a secure place apart from the
computer to assure access to your data. Your recovery password is required to unlock the
encrypted data on the volume if the BitLocker enters into a locked state. This recovery password
is unique to this particular BitLocker encryption. You cannot use it to recover encrypted data
from any other BitLocker encryption session.

9. On Choose how much of your drive to encrypt page, select the disk encryption option and
click Next.

10. Confirm that the Run BitLocker System check box is selected, and then click Continue.
11. Click Restart Now. The computer restarts and BitLocker verifies if the computer is

BitLocker-compatible and ready for encryption. If it is not, an error message alerting you to
the problem appears.

12. If it is ready for encryption, the Encryption in Progress status bar appears. You can monitor
the ongoing completion status of the disk volume encryption by dragging your mouse cursor
over the BitLocker Drive Encryption icon in the notification area at the bottom of your screen.
By completing this procedure, it is ensured that you have encrypted the operating system
volume and have created a recovery password unique to this volume. The next time you log
in, you will see no change. If the TPM changes or cannot be accessed, and if there are changes
to key system files, or if someone tries to start the computer from a product CD or DVD to
circumvent the operating system then, the computer switches to recovery mode until the recovery
password is supplied.
For more information regarding BitLocker, see the Microsoft® website (http://
technet.microsoft.com/en-us/library/cc732774.aspx).

Installing Hyper-V (For Windows 2008 R2 Standard)
To install Hyper-V for Windows 2008 R2 Standard:
1. Click Start, and select Administrative Tools>Server Manager.
2. In the left column, click Roles.
3. Select Add Roles and click Next to proceed.
4. Select the check box for Hyper-V component and click Next to continue.
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5. Click Next.
6. Follow the instructions and select the appropriate settings, click and then Install to start

installation.
7. Click Close and then press Yes to restart the system to complete the installation.

Installing Hyper-V (For Windows Server 2012 Standard)
To install Hyper-V for Windows Server 2012 Standard:

1. Press button from keyboard, click Server Manager.
2. On the Manage menu, click Add Roles and Features.
3. On the Before you begin page, verify that your destination server and network environment

are prepared for the role and feature you want to install. Click Next.
4. On the Select installation type page, select Role-based or feature-based installation and then

click Next.
5. On the Select destination server page, select a server from the server pool and then click Next.
6. On the Select server roles page, select Hyper-V.
7. To add the tools that you use to create and manage virtual machines, click Add Features. On

the Features page, click Next.
8. Click Next until Confirm installation selections page is displayed.
9. On the Confirm installation selections page, select Restart the destination server automatically

if required , and then click Install.
10. When installation is finished, verify the installation by opening the All Servers page in Server

Manager, select a server in which you have installed Hyper-V, and view the Roles and Features
tile on the page for the selected server.
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7 Installing Windows Server 2008 R2 Standard and
Windows Server 2012 Standard operating system on
virtual machines using HP media

Installing guest operating systems on Windows Server 2008 R2/Windows
Server 2012 Standard

For HP Factory installed ProLiant servers or ProLiant servers installed from HP-branded
Windows Server® 2008 R2/Windows Server 2012 Media DVD:

To install guest operating systems on Microsoft® Hyper-V from HP-branded Windows Server®
2008 R2 or HP-branded Windows Server 2012 Media DVD in full-installation mode, perform the
following:
1. Install HP-branded Windows Server® 2008 R2/Windows Server 2012 in full-installation

mode on the host server.
2. Enable the Hyper-V server role using Server Manager.
3. Map appropriate HP branded Windows Server 2008 R2/Windows Server 2012 operating

system media to the virtual machine created and start the operating system installation.
To install guest operating systems on Microsoft® Hyper-V in server-core mode, perform the following:
1. Install HP-branded Windows Server® 2008 R2/Windows Server 2012 in server-core mode

on the host server.
2. Install Microsoft® Hyper-V by using the command: start /w ocsetup

Microsoft-Hyper-V.
3. Click Yes to reboot the server to enable the changes.
4. Execute the following command from the command prompt if the guest operating system is

HP-branded Windows Server® 2008 R2:

NOTE: In the following command line after the word "Hewlett-Packard" there are 17 blank
spaces before the quotation mark that must be entered as part of the command.

Reg Add "HKLM\SOFTWARE\Microsoft\Windows
 NT\CurrentVersion\Virtualization" /v BiosLockString /t REG_SZ /d 
"Hewlett-Packard                 ”

If prompted to overwrite the registry string, choose Yes.
5. Execute the following command from the command prompt if the guest operating system is

HP-branded Windows Server 2012:

NOTE: In the following command line after the word "HP" there are 30 blank spaces before
the quotation mark that must be entered as part of the command.

Reg Add "HKLM\SOFTWARE\Microsoft\Windows 
NT\CurrentVersion\Virtualization" /v BiosLockString /t REG_SZ /d 
"HP                              "

If prompted to overwrite the registry string, choose Yes.
6. Map appropriate HP branded Windows Server 2008 R2 or HP-branded Windows Server

2012 operating system media to the virtual machine created and start the operating system
installation.

For non HP-branded Windows Server® 2008 R2 Media DVD
To install guest operating systems on Microsoft® Hyper-V using HP-branded Media in full-installation
mode, perform the following:

Installing guest operating systems on Windows Server 2008 R2/Windows Server 2012 Standard 21



1. Install Windows Server® 2008 R2 or HP-branded Windows Server 2012 in full-installation
mode on the host server.

2. Execute the following command from the command prompt if the guest operating system is
HP-branded Windows Server® 2008 R2:

NOTE: In the following command line after the word "Hewlett-Packard" there are 17 blank
spaces before the quotation mark that must be entered as part of the command.

Reg Add "HKLM\SOFTWARE\Microsoft\Windows 
NT\CurrentVersion\Virtualization" /v BiosLockString /t REG_SZ /d 
"Hewlett-Packard                 ”

If prompted to overwrite the registry string, choose Yes.
3. Execute the following command from the command prompt if the guest operating system is

HP-branded Windows Server 2012:

NOTE: In the following command line after the word "HP" there are 30 blank spaces before
the quotation mark that must be entered as part of the command.

Reg Add "HKLM\SOFTWARE\Microsoft\Windows 
NT\CurrentVersion\Virtualization" /v BiosLockString /t REG_SZ /d 
"HP                              "

If prompted to overwrite the registry string, choose Yes.
4. Enable the Hyper-V server role using Server Manager.
5. Map appropriate HP branded Windows Server® 2008 R2 or HP-branded Windows Server

2012 operating system media to the virtual machine created and start the operating system
installation.

To install guest operating systems on Microsoft® Hyper-V using HP-branded Media in server-core
mode, perform the following:
1. Install Windows Server® 2008 R2/Windows Server 2012 in server-core mode on the host

server.
2. Install Microsoft® Hyper-V by using the command: start /w ocsetup

Microsoft-Hyper-V.
3. Click Yes to reboot the server to enable the changes.
4. Execute the following command from the command prompt if the guest operating system is

HP-branded Windows Server® 2008 R2:

NOTE: In the following command line after the word "Hewlett-Packard" there are 17 blank
spaces before the quotation mark that must be entered as part of the command.

Reg Add "HKLM\SOFTWARE\Microsoft\Windows 
NT\CurrentVersion\Virtualization" /v BiosLockString /t REG_SZ /d 
"Hewlett-Packard                 ”

If prompted to overwrite the registry string, choose Yes.
5. Execute the following command from the command prompt if the guest operating system is

HP-branded Windows Server 2012.

NOTE: In the following command line after the word "HP" there are 30 blank spaces before
the quotation mark that must be entered as part of the command.

Reg Add "HKLM\SOFTWARE\Microsoft\Windows 
NT\CurrentVersion\Virtualization" /v BiosLockString /t REG_SZ /d 
"HP                              "

6. Map appropriate HP branded Windows Server® 2008 R2 or HP-branded Windows Server
2012 operating system media to the virtual machine created and start the operating system
installation.

22 Installing Windows Server 2008 R2 Standard and Windows Server 2012 Standard operating system on virtual machines
using HP media



For Smart Start/Intelligent Provisioning assisted installation for either HP-branded or
non HP-branded Windows Server® 2008 R2 Media DVD

1. After the operating system installation is complete, run the following command from the
command prompt:

NOTE: In the following command line after the word "Hewlett-Packard" there are 17 blank
spaces before the quotation mark that must be entered as part of the command.

Reg Add "HKLM\SOFTWARE\Microsoft\Windows 
NT\CurrentVersion\Virtualization" /v BiosLockString /t REG_SZ /d 
"Hewlett-Packard                 ”

If prompted to overwrite the registry string, choose Yes.
2. Execute the following command from the command prompt if the guest operating system is

HP-branded Windows Server 2012.

NOTE: In the following command line after the word "HP" there are 30 blank spaces before
the quotation mark that must be entered as part of the command.

Reg Add "HKLM\SOFTWARE\Microsoft\Windows 
NT\CurrentVersion\Virtualization" /v BiosLockString /t REG_SZ /d 
"HP                              "

If prompted to overwrite the registry string, choose Yes.
3. Enable the Hyper-V server role using Server Manager.
4. Map HP branded or non HP branded Windows Server® 2008 R2 or HP-branded Windows

Server 2012 operating system media to the virtual machine created and start the operating
system installation.

Installation on VMware Virtual machines
1. For installation and configuring VMware on Windows® 2008 R2 Standard and Windows®

2012 Standard, see the VMware documentation.
2. After creating a Virtual machine, go to the path where it is created and open the <VM guest

name>.vmx file with note pad and add the following line:
smbios.ReflectHost = "TRUE"

3. Save and close the file.
4. Map HP branded Windows® OS Media to the virtual machine created and start OS

installation.
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8 Post-installation tasks for HP ProLiant 300 series servers
Web-based Management utility (HP System Management Homepage)

Use a local administrator account and password when logging into the Web-based Management
utility (shortcut link available on the desktop of the Administrator Profile). The account login name
must be entered in the following format:
domain name\login name

It is necessary to modify the display resolution to a higher mode to properly view the Management
page.

Installing the HP Management Agents
IMPORTANT: For security reasons, first obtain a 64-bit encrypted password certificate to set your
password. The password certificate can be obtained from an HP Systems Insight Manager Certificate
Server. For information about how to set and acquire the certificate, see the HP Insight Management
Agents User Guide.

To install the HP Management Agents, complete the following steps:
1. If your operating system is Windows Server 2008 R2, click Start, and select All

Programs>Pre-install Features>HP Service Pack for ProLiant.

If your operating system is Windows Server 2012, Press button from keyboard, right click
anywhere in the Start page, then click All Apps>Pre-Install Features>HP Service Pack for
ProLiant.

2. On Welcome Screen, Click Next.
3. Click Next on Source Selections page.
4. Select localhost check box and click on Enter Credentials button.
5. On Enter Credentials for Host page, choose Use Local Host's Current Domain Credentials and

click OK.
6. After completing Self discovery of components, click Next.
7. Click Select Components.
8. Ensure that you install SNMP service prior to installing HP Insight Management Agent for

Windows Server .
9. Select HP Insight Management Agent for Windows Server check box and click OK.
10. Click Install on Review/Install Updates page.
For more information about the HP Management Agents, see the HP Insight Management Agents
User Guide.

Installing the Network Teaming and Configuration Utility
The CPQTEAM Utility enables multiple NICs to be teamed together. You must run the HP Software
update manager to install the CPQTEAM utility.
During the CPQTEAM software installation process, a message might appear, stating that the
CPQTEAM.DLL file is needed. A default path appears in the message box. Click OK to accept the
path and continue with the installation.

Using HP Software Update Manager (HPSUM)
The HPSUM for the operating system is automatically installed when the server software is installed.
This software contains device drivers and utilities that take advantage of specific capabilities offered
with ProLiant server products. These drivers are provided for use with ProLiant hardware only.
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To launch HPSUM:
1. For Windows Server 2008 R2 operating system, click Start, and then select All

Programs>Pre-Install Features>HP Service Pack for Proliant.

For Windows Server 2012 operating system, Press button from the keyboard and right
click anywhere in the Start page, then click All Apps>Pre-Install Features>HP Service Pack for
ProLiant.

2. Follow the on-screen instructions when the setup program is launched.
To manually launch the setup program:
1. Click Start>Run.
2. Enter the following path in the text box:

C:\HPSUM\SETUPEX.EXE

3. Click OK.
4. After the setup program is launched, follow the on-screen instructions.

Configuring array controllers
If an array controller was purchased with the server, run the online ACU to set up the remaining
physical drives for use.

IMPORTANT: Microsoft® Internet Explorer is required to run the ACU. Internet Explorer is used
to interface with the array controller. For the page to display properly, the server IP address must
be included in the trusted sites list. Internet Explorer must be restarted after adding the IP address
to the trusted sites list for the settings to take effect.

To configure array controllers:
1. For Windows Server 2008 R2 operating system, click Start, and select All Programs>HP

System Tools>HP Array Configuration Utility>HP Array Configuration Utility.

For Windows Server 2012 operating system, Press button from the keyboard and right
click anywhere in the Start page, then click All Apps>HP System Tool>HP Array Configuration
utility>HP Array Configuration utility.

2. Select whether you want to enable remote administration when prompted.
3. Click OK.
4. When prompted for the Web-based Management password, enter the credentials for either

the local administrator account or a local user account in the following format:
domain name\login name

5. Configure the remaining physical drives into logical drives, and run Disk Administrator to
partition and format the additional drive space.
For more information about using the ACU, see the HP Online Help.

Using Management Agents
The Management Agents for servers are installed during the setup process. For more information
about the Management Agents, see the HP Insight Management Agents User Guide.
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A Troubleshooting
Reinstalling the operating system

If the server operating system becomes corrupt, reinstall it using the SmartStart CD or HP Intelligent
Provisioning, the HP Management CD, and the HP branded version of the Microsoft® Windows®
operating system CD.
To reinstall the operating system, boot the server from the SmartStart CD or HP Intelligent Provisioning
and follow the on-screen installation path instructions.

CAUTION: Booting from the SmartStart CD permanently erases any disk partitions and data
currently on the disk drive.

For information about using SmartStart or HP Intelligent Provisioning, see the documentation included
in the ProLiant Essentials Foundation Pack provided with the server.
The operating system can also be reinstalled by booting the server from the HP branded version
of the Microsoft® Windows® operating system CD. During the installation process, you might be
prompted to press the F6 key to supply the appropriate storage driver. If so, the storage driver can
be obtained from the SmartStart CD or from the HP Technical Support website.
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B Technical support
Before you contact HP

Be sure to have the following information available before you call HP:
• Technical support registration number (if applicable).
• Product serial number
• Product model name and number
• Product identification number
• Applicable error messages
• Add-on boards or hardware
• Third-party hardware or software
• Operating system type and revision level

HP contact information
For the name of the nearest HP authorized reseller and HP technical Support World Wide:
• See the Contact HP worldwide (in English) webpage:

(http://welcome.hp.com/country/us/en/wwcontact.html).

For HP technical support:
• In the United States, for contact options see the Contact HP United States webpage (http://

welcome.hp.com/country/us/en/contact_us.html).

◦ If you have purchased a Care Pack (service upgrade), see the HP website (http://
www.hp.com/services/carepack).

Customer self repair
What is customer self repair?
HP's customer self-repair program offers you the fastest service under either warranty or contract.
It enables HP to ship replacement parts directly to you so that you can replace them. Using this
program, you can replace parts at your own convenience.
A convenient, easy-to-use program:
• An HP support specialist will diagnose and assess whether a replacement part is required to

address a system problem. The specialist will also determine whether you can replace the
part.

• For specific information about customer replaceable parts, refer to the maintenance and service
guide on the HP website (http://www.hp.com/support).

HP customer support
HP customer support offers Software Support, and Integrated Hardware and Software Support
services. For more information, see the following links:
• Software Support Services (http://www.hp.com/services/swtechnology) – Three incidents

and 9 x 5 standard telephone support are included for the operating system and a wide range
of Microsoft® applications.

• Hardware Support (http://www.hp.com/services/hardwaresupport) – A range of hardware
support services are available for the server.
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• Support Plus (http://www.hp.com/services/swsupport) – One year of integrated hardware
and software support is included for the server.

• 90-day getting started software telephone support – For ProLiant servers, technical advisory
support, including installation assistance, is available for HP preinstalled third-party software
from the HP website (http://www.hp.com) or by telephone for 90 days from the date of
purchase.

IMPORTANT: Support applies only to the original HP hardware and software configuration
shipped to the customer.
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C Acronyms and abbreviations
ACU Array Configuration Utility
COA Certificate of Authenticity
CPQTEAM Network Teaming and Configuration
EULA End User License Agreement
HPSUM HP Software Update Manager
iLO Integrated Lights-Out
IP Internet Protocol
NIC Network Interface Controller
NTFS NT File System
PCI Peripheral Component Interface
RAS Remote Access Service
SNMP Simple Network Management Protocol
TCP/IP Transmission Control Protocol/Internet Protocol
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